*

statek

  • **
  • 8 posts
"Recaptcha validation has failed" on fresh installed OsClass
« on: April 09, 2025, 12:46:54 PM »
Hello.

Fresh installed OsClass v8.2.1 shows error "Recaptcha validation has failed" on post new ad page. All Recaptcha keys was set up succesfullly.

Also has this warning in error_log:

[09-Apr-2025 13:26:31 Europe/Kiev] PHP Warning:  file_get_contents(google.com/recaptcha/api/siteverify): failed to open stream: no suitable wrapper could be found in /home/huculiai/public_html/ads.kosiv.biz/oc-includes/vendor/google/recaptcha/src/ReCaptcha/RequestMethod/Post.php on line 80

the code on line 80 is:
$response = file_get_contents($this->siteVerifyUrl, false, $context);

Any suggestions?

Marked as best answer by statek on April 09, 2025, 04:13:15 PM
*

MB Themes

Re: "Recaptcha validation has failed" on fresh installed OsClass
« Reply #1 on: April 09, 2025, 01:45:54 PM »
I would double check if your server has fallowurl open enabled and curl enabled
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

*

statek

  • **
  • 8 posts
Re: "Recaptcha validation has failed" on fresh installed OsClass
« Reply #2 on: April 09, 2025, 04:15:57 PM »
Thank you!
"curl" was enabled but enabling "allow_url_fopen" in php.ini solved the problem!

*

MB Themes

Re: "Recaptcha validation has failed" on fresh installed OsClass
« Reply #3 on: April 10, 2025, 09:44:47 AM »
Great, thanks for feedback ;)
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots