*

David S

  • *
  • 3 posts
struct.sql is failing on install for cars, jobs, and real estate attributes plugins

when running sql in PhpMyAdmin, they're all receiving errors like this:

1005 - Can't create table `dev_osclass`.`oc_t_item_house_description_attr` (errno: 150 "Foreign key constraint is incorrectly formed")

All of the tables in the database are InnoDB except oc_t_item_description

This is a fresh install of osclass 8.3.0 using MySQL version: 5.5.5-10.3.39-MariaDB

Appreciate insight on how to correct this.

*

MB Themes

Usually it happens when (for some reason) database tables engine is changed from InnoDB to something different.
Some hostings and auto-installations does that.
Then, foreign key cannot be created.
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

*

David S

  • *
  • 3 posts
As I noted, this is a fresh install and all of the tables are Innodb except one. I see many other people having same problem. How can we get this resolved?

*

MB Themes

Then open struct.sql, create table and run foreign key sql to see details.
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots