Hi i did try multiple times to update osclass, manual and in automatic from the admin panel and i always have the same problem.

In the Admin panel it gives me an 404 error wen i try to go to Media and from the front panel wen i try to post a new ad or from the user panel wen i navigate to User Listings.

I did Disabled/Enabled the permalinks and click Save changes, and swaped mi PHP from 8.1 to 8.3 and the problem its still there.

I did a new Osclass instalation from scratch and it works perfectly, but i need to update a large number of websites so doing a new instalation on each one its not an option for me.

Anyone else had or has similar problems and solved ?

*

MB Themes

Re: 404 error after Osclass After Automatic and Manual update (v8.3.0)
« Reply #1 on: June 06, 2025, 09:09:26 PM »
Reupload osclass files manually.
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

Re: 404 error after Osclass After Automatic and Manual update (v8.3.0)
« Reply #2 on: June 06, 2025, 11:48:02 PM »
Thank you very much for advice but unfortunately it's not working even i upload them manually after and if i change from php 8.1 to php 8.3 it gets worse in the admin panel i get a lot more 404 errors
« Last Edit: June 07, 2025, 12:40:09 AM by Cristinel Constantin Chiriac »

*

MB Themes

Re: 404 error after Osclass After Automatic and Manual update (v8.3.0)
« Reply #3 on: June 07, 2025, 08:32:58 AM »
404 has nothing to do with php version and usually shown in backoffice when files are missing, are corruoted or not readable.
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

Re: 404 error after Osclass After Automatic and Manual update (v8.3.0)
« Reply #4 on: June 07, 2025, 10:15:57 AM »
404 has nothing to do with php version and usually shown in backoffice when files are missing, are corruoted or not readable.

Can i give you access to one of mi projects to try your self and see whats wrong so if it's an bug it get's fixed in the next update ?

Because i tried all the possible options and nothing seems to work honestly, and you are write is not an 404 is an 502 error.

*

MB Themes

Re: 404 error after Osclass After Automatic and Manual update (v8.3.0)
« Reply #5 on: June 07, 2025, 01:21:52 PM »
502 will not be related to osclass
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

Re: 404 error after Osclass After Automatic and Manual update (v8.3.0)
« Reply #6 on: June 09, 2025, 02:09:37 PM »
502 will not be related to osclass


Found the Error it's an conflict with the Favorite Items Plugin wen it's activated it messes up some Admin and Settings Options, and in the main user interface creates some 502 errors.


*

MB Themes

Re: 404 error after Osclass After Automatic and Manual update (v8.3.0)
« Reply #7 on: June 09, 2025, 02:18:05 PM »
But 502 is not related to Osclass, never seen such case where osclass would cause 502.
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

Re: 404 error after Osclass After Automatic and Manual update (v8.3.0)
« Reply #8 on: June 09, 2025, 02:27:58 PM »
But 502 is not related to Osclass, never seen such case where osclass would cause 502.
Sorry it's mi mistake it was not a 502 error but Error code 521, and uninstaling that plugin the update and all the functions now work continue to test it and sometimes wen you click back in the browser it trowns that error back not always. May be because of Cloudflare i dont know? The think i now is that it was not happening it before the update.
« Last Edit: June 09, 2025, 02:30:03 PM by Cristinel Constantin Chiriac »

*

MB Themes

Re: 404 error after Osclass After Automatic and Manual update (v8.3.0)
« Reply #9 on: June 09, 2025, 02:51:12 PM »
Cloudflare - possible, try to disable, saw various issues from cloudflare already.
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

Re: 404 error after Osclass After Automatic and Manual update (v8.3.0)
« Reply #10 on: June 09, 2025, 03:04:22 PM »
Cloudflare - possible, try to disable, saw various issues from cloudflare already.

Unfortunately for me i cannot disable cloudflare or bunny because i run massive on it mi SSL are from it all mi DNS etc. and i run all 13 actual websites like this and the next 10 will be  basically the same setup. I have a fresh 8.3 Osclass instalation and it's working perfectly i notice the plugin problem on the fresh instalation wen i did install it and saw it begin trowing that 521 error after i disable the Fav plugin all worked back with no problems. I run Region based subdomains and child theme on all of them in the next days i will buy more plugins and test them if i notice something wrong i will notify you under this thread.