*

jj2k

  • *
  • 4 posts
Help - Mail Server is not sending emails
« on: August 15, 2020, 03:21:01 PM »
Hello Friends,

Pls. help me .......
I am receiving emails only for user gets registered and Ad is published.
Other things are mostly not working ...this include:
Password reset...
No email is coming on Gmail or Yahoo or even MSN.

In addition to this, any way to INSTALL FRESH OSCLASS SCRIPT without distrubing database and theme settings?

appreciate help out


Thank you

*

MB Themes

Re: Help - Mail Server is not sending emails
« Reply #1 on: September 14, 2020, 03:17:00 PM »
Check docs:
https://docs.osclasspoint.com/setting-up-a-mail-server

Or discuss with your hosting provider.
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

*

son

  • *
  • 6 posts
Re: Help - Mail Server is not sending emails
« Reply #2 on: October 13, 2020, 08:17:56 AM »
Hi,
I configured gmail server like the demo video but it doesn't send any kind of emails. If a user is registered it doesn't send mail. If somebody sends a message of an ad neither.

Can you help me?

thanks

*

MB Themes

Re: Help - Mail Server is not sending emails
« Reply #3 on: October 13, 2020, 10:01:33 AM »
@son
You can test in email templates if your mail server is functional or not.
Usually problem is with smtp authentication (try to enable/disable), tls and port.
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

*

pixelpadre2

  • *
  • 22 posts
Re: Help - Mail Server is not sending emails
« Reply #4 on: October 14, 2020, 03:51:24 PM »
Hello Friends,

Pls. help me .......
I am receiving emails only for user gets registered and Ad is published.
Other things are mostly not working ...this include:
Password reset...
No email is coming on Gmail or Yahoo or even MSN.

In addition to this, any way to INSTALL FRESH OSCLASS SCRIPT without distrubing database and theme settings?

appreciate help out


Thank you

Gmail sends all of my emails into spam folder.  Check gmail SPAM folder.
« Last Edit: October 14, 2020, 04:01:58 PM by pixelpadre2 »

*

son

  • *
  • 6 posts
Re: Help - Mail Server is not sending emails
« Reply #5 on: October 14, 2020, 10:32:38 PM »
I solved enabling POP over SMTP.

But now when an user is registered osclass doesn't send the validation mail, but in admin mail I get the new registration, or if a non registered user posts a new listing it receives the mail to edit.

How can I solve it?

I'm working on a fresh installation.

Thanks

*

MB Themes

Re: Help - Mail Server is not sending emails
« Reply #6 on: October 14, 2020, 11:10:59 PM »
Osclass sends all emails or none, that is weird.
Have you checked error log? Spam folder?
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

*

son

  • *
  • 6 posts
Re: Help - Mail Server is not sending emails
« Reply #7 on: October 15, 2020, 08:10:50 AM »
Hi,

there aren't in the spam folder.

Where can I see the error log?

Thanks.


*

MB Themes

Re: Help - Mail Server is not sending emails
« Reply #8 on: October 15, 2020, 12:27:06 PM »
@son
Discuss with your hosting provider.
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

*

son

  • *
  • 6 posts
Re: Help - Mail Server is not sending emails
« Reply #9 on: October 15, 2020, 03:20:17 PM »
They says that the problem is with osclass. Because the mail config works or not works, but it doesn't works randomly.

*

MB Themes

Re: Help - Mail Server is not sending emails
« Reply #10 on: October 15, 2020, 04:27:58 PM »
Then it cannot be problem of osclass.
Test different mail server, ie gmail
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

*

jcarrolo01

  • ***
  • 163 posts
Re: Help - Mail Server is not sending emails
« Reply #11 on: October 16, 2020, 08:58:24 AM »
Good day...

After reading this i try on my site with osclass 4.1.0..

I try to send emails from admin dashboard, email models, and yes, i got an error sending emails..

For me, and for now is not a big issue becase is a site in preparation to be launched, but the issue is there..

Best regards
Joao carrolo

*

jcarrolo01

  • ***
  • 163 posts
Re: Help - Mail Server is not sending emails
« Reply #12 on: October 18, 2020, 01:49:04 PM »
Hello..

I made several trys, and the conclusion is.

With smtp authentication: dosn't work
Without smtp authentication: work perfectlly

Best regards
Joao carrolo


*

MB Themes

Re: Help - Mail Server is not sending emails
« Reply #13 on: October 19, 2020, 07:24:07 PM »
@jcarrolo01
Something like that worked for me as well.

If you look on docs updated few months ago:
https://docs.osclasspoint.com/setting-up-a-mail-server

I have noticed:
"Note: In some hostings option “SMTP Authentication” may not work (depends if hosting supports that), make sure to try with & without this setting."
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

*

jcarrolo01

  • ***
  • 163 posts
Re: Help - Mail Server is not sending emails
« Reply #14 on: October 19, 2020, 08:56:21 PM »
Hello...

Maybe on this point i disagree with you...

Same site send emails with smtp authentication in osclass 3.9.0, after upgrade to 4.1.1 don't send anymore with smtp activated.. The only changed variable here is the upgrade, nothing else...

But is working  :) :)

Best Regards
João Carrolo