This topic contains a post which is marked as Best Answer. Press here if you would like to see it.
*

Artem

  • **
  • 6 posts
Wrong value for Ukrainian language
« on: June 06, 2021, 09:11:36 PM »
Hello. I would like to know where to change the values for the Ukrainian language in the Osclass?

The fact is that everywhere in Osclass ICU Locale is indicated as "uk_UK". That's wrong!
The correct value should be: "uk_UA"
Here is the confirmation: localeplanet.com/icu/uk-UA/index.html

Therefore, some functions for the Ukrainian language do not work correctly. If you name the language folder correctly "uk_UA", then the Osсlass will not see it.
In which files and what needs to be changed so that the Osklass can see correctly ICU Locale for Ukrainian language?

Here is one of the bugs in the gamma theme:

Thank you

*

MB Themes

Re: Wrong value for Ukrainian language
« Reply #1 on: June 06, 2021, 09:58:31 PM »
I am not aware that language code could cause any bug.
You can rename flag to one needed.
There are several strange values, ie japan is as JA, not JP... but this willnot cause bugs.
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

*

Artem

  • **
  • 6 posts
Re: Wrong value for Ukrainian language
« Reply #2 on: June 07, 2021, 01:07:01 AM »
The problem is that it's not just about the flag. For example, the language of Facebook comments is displayed incorrectly. Also, the language of the maps is displayed incorrectly. That is, this leads to errors in the display of external services that are configured in a generally accepted format

Marked as best answer by frosticek on June 07, 2021, 03:03:49 PM
*

MB Themes

Re: Wrong value for Ukrainian language
« Reply #3 on: June 07, 2021, 11:02:31 AM »
@Artem
I understand, but I do not think all you say is related to internal language code used by osclass.
Anyway we've updated code on our servers, so if you remove and add language, it should use uk_UA.
« Last Edit: June 07, 2021, 11:07:36 AM by MB Themes »
  To get fast support, we need following details: Detail description, URL to reproduce problem, Screenshots

*

Artem

  • **
  • 6 posts
Re: Wrong value for Ukrainian language
« Reply #4 on: June 07, 2021, 01:41:13 PM »
Thank you very much for the prompt solution. Checked, now the problem with Facebook comments and flag display is solved. I think this will solve the rest of the problems with the translation of external services.

Pleased the fast work of your support  :)